No spark

Discussion in 'Maintenance' started by mickey, Jul 22, 2020.

  1. mickey

    mickey New Member

    Joined:
    Dec 24, 2017
    Messages:
    40
    Likes Received:
    0
    Hi all hope someone can help I’m at my whits end with my 2005 cbr1000rr I did a cylinder head rebuild this year after putting it back together I got no spark engine turns over have checked everything possible can smell fuel from the bike when turning it over I got the malfunction light on not flashing I read some where it could be a fault in the fuel system somewhere can anyone give me something to check or go on as I’m really out of ideas
     
  2. Black & White

    Black & White New Member

    Joined:
    Jun 27, 2019
    Messages:
    301
    Likes Received:
    101
    Hello sport. Have you had any luck?
     
  3. mickey

    mickey New Member

    Joined:
    Dec 24, 2017
    Messages:
    40
    Likes Received:
    0
    No sport my timing is a little out I’m going to correct it and also check the valve clearance and see what I come up with
     
  4. Black & White

    Black & White New Member

    Joined:
    Jun 27, 2019
    Messages:
    301
    Likes Received:
    101
    Neither of those will cause a lack of ignition spark. Have you had the valves out?
    Problems like this are nearly always down to something not connected. Cam & crank sensors, fuel rail sensor etc.
     
  5. mickey

    mickey New Member

    Joined:
    Dec 24, 2017
    Messages:
    40
    Likes Received:
    0
    You name it I have checked it or changed it I read some where there is a diode in the ignition that can fail and this can stop it from sparking
     
  6. Black & White

    Black & White New Member

    Joined:
    Jun 27, 2019
    Messages:
    301
    Likes Received:
    101
    Have you got the workshop manual & a multimeter? The troubleshooting sections are well worth going through. Ignition system is chapter 18.
     

Share This Page