The rebuild and upgrade

Discussion in 'Mods, Upgrades, Accessories and Products' started by thewiz, Dec 28, 2017.

  1. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Fitted the rear tire and stuck the chain on. Have not done it up properly yet. But damn this looks so good :D:eek:

    28.jpg

    29.jpg
     
    • Like Like x 5
  2. PauloHRC

    PauloHRC New Member

    Joined:
    Sep 3, 2017
    Messages:
    300
    Likes Received:
    98
    Looking good......what size sprocket did you go for???
     
  3. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    -1 on the front (15) and +1 on the rear (43) mate.
     
    • Like Like x 1
  4. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Spent an hour with the bike today. Sadly i realised that the painted left fairing is wrong. It has been sprayed with metallic paint.... So it looks off from the rest of the bike now. Gonna have to take it off and have a little chat with the painter.

    Also ordered 2x dust seals for the front tire, so they should be comming in this week so i can get the front wheel on. Head fairing on aswell ;)

    But, still, it is comming togheter nicely.

    30.jpg
     
    • Like Like x 1
  5. nigelrb

    nigelrb New Member

    Joined:
    Nov 2, 2017
    Messages:
    601
    Likes Received:
    190
    Looking good. Red hoses are a gem.

    These projects are so much easier with a good workspace. No climbing over bits of crap and dolls houses, skateboards, and the ex's boxes of, 'I'Il pick them up later, honey,' marital treasures!!:eek::eek:
     
    • Agree Agree x 1
    • Funny Funny x 1
  6. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Well, tried to start the bike today, but no luck. Just cranks, and light going all crazy. Not sure if its a bad charge on the battery or PCV or something. Battery sounded pretty tired after a few trys, so might charge it up to see if that was the problem. But the PCV don't light up when ignition is on......
     
  7. Nigelg79

    Nigelg79 Member

    Joined:
    May 25, 2015
    Messages:
    389
    Likes Received:
    73
    Maybe a dodgy earth somewhere or muck in one of your electrical connectors? I had similar after fitting my quickshifter.
     
  8. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Charged the battery today, and the bike fired right up. PCV also showed a green light on power. Success!

    Bike has been sitting for a while, so the battery had to low charge i guess.
     
    • Like Like x 3
  9. Nigelg79

    Nigelg79 Member

    Joined:
    May 25, 2015
    Messages:
    389
    Likes Received:
    73
    Glad you got it sorted.
     
  10. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Update! Wheels all mounted, fairings back on, chain is mounted. Looks stunning. Need to sort out some stickers / sticker removal and order a asv brake lever. Going to be looking at PCV maps and when spring comes i need to calibrate the speedodrd.

    Parked it next to my desk at work, haha :D:D Easy access to PCV hookup :D

    [​IMG]

    [​IMG]
     
    • Like Like x 2
  11. nigelrb

    nigelrb New Member

    Joined:
    Nov 2, 2017
    Messages:
    601
    Likes Received:
    190
    Mint. I guess you don't work on the 23rd floor?:)
     
  12. thewiz

    thewiz Member

    Joined:
    Oct 30, 2016
    Messages:
    213
    Likes Received:
    79
    Hehe no ;)
     

Share This Page